RC-500 Compressor - Fat Channel Plug-In *

Product Details

  • PreSonus' RC500 signature FET compressor. Emulated
  • Compatible with VST3, AudioUnit and AAX compatible host applications (requires Fat Channel XT)
  • Compatible with Studio One Artist  and Professional (Versions 3.5.6 and higher)
  • Compatible with Studio One Prime with separately purchased Fat Channel XT (Versions 3.5.6 and higher)
  • Also compatible with StudioLive Series III Console and Rack Mixers
  • Functions as an additional Compressor model in the Fat Channel XT Plugin in Studio One and compatible host applications
  • Functions as an additional Compressor model in the Fat Channel processing section of StudioLive Series III Mixers
  • Compatible Mixer Models:
    • StudioLive 16 Series III
    • StudioLive 24 Series III
    • StudioLive 32 Series III
    • StudioLive 16R
    • StudioLive 24R
    • StudioLive 32R

FET-based compressors such as the one in the PreSonus RC 500 use transistors to emulate a triode tube’s operation and sound. This type of compressor generally provides a faster attack time and better repeatability than the optical compressors typically found in channel strips. Modeled after PreSonus' RC500 signature FET compressor, this plug-in provides an ultra-fast attack time and repeatable performance. 

Included in the free PreSonus Bundle

System Requirements

A VST3, AudioUnit or AAX compatible host application (requires separately purchased Fat Channel XT)
-OR-
Studio One Artist or Professional (Versions 3.5.6 and higher)
-OR-
Studio One Prime with separately purchased Fat Channel XT (Versions 3.5.6 and higher)
-OR-
​A StudioLive Series III Console or Rack Mixer  (Firmware Version 1.7 or higher)


Computer Requirements:

Mac OS X 10.8.5 or higher
Intel® Core™ 2 Duo processor
(Intel Core i3 or better recommended)

Windows 7 x64/x86 SP1 + platform update, Windows 8.1 x64/x86, Windows 10 x64/x86
Intel Core 2 Duo or AMD® Athlon™ X2 processor
(Intel Core i3 or AMD Athlon X4 or better recommended)


Mixer Minimum Firmware Requirement:

Version: 1.7.0 or higher